Netztaucher

Erkenntnisse eines Netzbewohners

Timecode addieren in MS Excel / OpenOffice.org

Hinterlasse einen Kommentar


Ein professionelles Band in der Filmproduktion hat einen so genannten Timecode. Dieser besteht aus Stunde, Minute, Sekunde und Frames. Eine Sekunde hat bei PAL/Video 25 Frames.

Möchte man solch einen Timecode nun in Excel addieren, dann gibt es keine vorgefertigte Lösung um dies zu tun. Man kann sich aber mit dieser zweigeteilten Variante behelfen.

Dazu legt man ein Feld als Zeit-Feld an und ein zweites Feld als Zahlenfeld. Die Zeiten kann Excel selbst addieren. Bei den Frames müssen wir nun nachhelfen. Nehmen wir also an, dass A1 bis A4 die Zeit enthält und B1-B4 die jeweiligen Frames, dann sieht die Lösung so aus.

Zeit:

=SUMME(A1:A4)+(GANZZAHL(SUMME(B1:B4) / 25) / 86400)

Frames:

=REST(SUMME(B1:B4);25)

Die Zeit wird erst ganz normal mit SUMME addiert, dann addieren wir dazu den ganzzahligen Teiler von der Summe der Frames. Oder anders ausgedrückt: „Wie viel mal passt 25 in die Summe der Frames?“ Denn bei 25 Frames ist die Sekunde voll und wir müssen den Wert auf die Zeit addieren. Ganzzahlig, weil wir nur volle Sekunden addieren wollen. Da in Excel die „1“ (bei der Zeit-Formatierung) für einen Tag steht müssen wir den Wert noch auf Sekunden bringen, also teilen wir durch 24 Stunden x 60 Minuten x 60 Sekunden = 86400.

Bei den Frames teilen wir durch den 25 und geben den Rest aus. Alle vollen 25 Frames haben wir ja bereits im ersten Schritt zu den Sekunden hinzu gezählt.

Als Ergebnis haben wir die korrekte Summe von den angewählten Timecodes.

Nachtrag: Die oben verwendeten Formeln funktionieren exakt so auch in OpenOffice.org!

Autor: Torsten

Webworker, Moderator im deutschen WordPress.com Supportforum und lebendiges Videoformate-Lexikon.

Schreibe einen Kommentar

Trage deine Daten unten ein oder klicke ein Icon um dich einzuloggen:

WordPress.com-Logo

Du kommentierst mit Deinem WordPress.com-Konto. Abmelden / Ändern )

Twitter-Bild

Du kommentierst mit Deinem Twitter-Konto. Abmelden / Ändern )

Facebook-Foto

Du kommentierst mit Deinem Facebook-Konto. Abmelden / Ändern )

Google+ Foto

Du kommentierst mit Deinem Google+-Konto. Abmelden / Ändern )

Verbinde mit %s